4.5 freeze and out of memory

You can ask general questions, share opinions or advices about FBackup
webdev51
Posts: 3
Joined: Mon Nov 29, 2010 8:57 pm

Postby webdev51 » Tue Nov 30, 2010 6:25 am

Hi, FBackup 4.4 worked great for me, but 4.5 doesn't. I don't know if it's a change in the program or if I have too many files in my latest backup. The computer is a couple of months old, with only a couple of background apps running (TrueCrypt and virus checkers), and no applications running during the backup except for FBackup. Same configuration as when I was using 4.4.


With virus checkers running, FBackup 4.5 locked my computer. When I rebooted, turned off the virus checkers, and restarted the backup after quick formatting the destination drive, FBackup appears to have run out of memory, according to the log file below.


FBackup 4.5 seems to work fine for me when backing up <2GB with 137 folders and 517 files. But when trying to backup one 1TB drive to another, I got the errors below. I'm doing a simple mirror, no encryption, one drive to another, excluding the Recycle Bin.


Here are the folders on the drive:


1. 52.7 GB, 26 files, 9 folders

2. 18.4 GB, 16K files, 1.2K folders

3. 28.2 MB, 21 files, 5 folders

4. 381 GB, 1.1 million files, 91K folders

5. 215 GB, 817K files, 55K folders

6. 486 MB, 27 files, 19 folders

7. 7.9 MB, 58 files, 1 folder

8. 16.3 GB, 141 files, 9 folders


FBackup 4.4 worked fine for this scenario, but maybe I have many more files now or there's a problem with 4.5. I haven't tried going back to 4.4 yet.


Also, a minor issue: When launching FBackup 4.4 and 4.5 from the taskbar, the icon highlights like it's going to launch, but then the outline fades away like it's shutting down. But, after 5-10 seconds, it launches correctly and highlights the icon as expected.


Thanks!


-- Ed


[November 22, 2010 4:55:05 AM] FBackup 4.5.232

[November 22, 2010 4:55:05 AM] Search for "Warning: " and "Error: " to locate warnings and errors in this log file

[November 22, 2010 4:55:05 AM] Starting backup for "Data Backup" at November 22, 2010 4:55:05 AM

[November 22, 2010 4:55:05 AM] Operating system: Windows 7 Professional (build 7600)

Processor[0] : AMD Athlon(tm) II X4 635 Processor

Processor[1] : AMD Athlon(tm) II X4 635 Processor

Processor[2] : AMD Athlon(tm) II X4 635 Processor

Processor[3] : AMD Athlon(tm) II X4 635 Processor

Physical memory (free/total) : 2714 MB/3838 MB

Display (res/color/DPI) : 1920X1200/32 bit/96

System font (name/height/size/charset) : Segoe UI/-12/9/1

Admin/BkPriv/RePriv : False/False/False

IsWOW64 : True

Locale : English (United States)


...


[November 22, 2010 8:38:20 AM] Warning: SQL error "hStmtSpanFiles" - SQLite_Finalize, out of memory - a malloc failed (SQL04)

[November 22, 2010 8:38:20 AM] Waiting for user input

Some of the files in the backup were not written correctly.

Do you want to abort the backup?

[November 22, 2010 10:53:29 AM] Continuing


Total number of files added to backup: 1152465

Total number of folders added to backup: 92022

Total size of files added to backup: 469,249,480.15 KB

Number of files excluded: 335005

Number of folders excluded: 36979

Next scheduled backup:

Backup completed at November 22, 2010 10:53:29 AM with 0 error(s), 1 warning(s)



Softland
Posts: 1647
Joined: Thu May 23, 2013 7:57 am

Postby Softland » Tue Nov 30, 2010 7:00 pm

Hi,


We don't have such problems when launching FBackup.


Please send us the fkc catalog file from View->Open Folder->Destination folder.

Put the file into a zip archive and send it to info[at]fbackup[dot]com




Return to “General”