Build 5.0.218

You can ask general questions, share opinions or advices about FBackup
Post Reply
Jim Rockford
Posts: 20
Joined: Tue Oct 15, 2013 8:19 pm

Build 5.0.218

Post by Jim Rockford »

Okay, so I get an announcement from Softland that there's an update to what has so far been an awful updated piece of once-functional software in FBackup. I already have installed Build 5.0.192. I download the brand new update and attempt to install it. What happens? I'm immediately informed by the installer that build Build 5.0.192 has already been installed. The "new" update installer is apparently oblivious to the fact that it supposedly is Build 5.0.218.

This is getting comically amateurish. I must ask...why did you guys decide to wreck a perfectly fine piece of software? Are things so bad that you cannot even build an installer that works correctly, one that correctly recognizes the version that it is supposed to be installing?

Yeah, I do hate to complain about free software, which is why you're hearing from me only for the first time on this forum. But I'm compelled now to tell Softland that you've been screwing things up for quite a while now and are not inspiring much confidence. Is the idea eventually to ask people to pay a nominal fee for your software? Do you think that these amateurish, slow, and disfunctional updates are going to do anything but drive away potential customers?

Hey, how about actually providing a link that works to the supposedly new update 5.0.218? I know it's a lot to ask for, but hey, sometimes you just gotta say what the fuc@ and make your move.

Jim

Adrian (Softland)
Posts: 1681
Joined: Thu May 23, 2013 7:57 am

Re: Build 5.0.218

Post by Adrian (Softland) »

Hi,

We think there was a cache somewhere and that tried to install you the old version (192).
Here is a link to the full installer: http://www.fbackup.com/download/setup/fbsetup-full.exe

Jim Rockford
Posts: 20
Joined: Tue Oct 15, 2013 8:19 pm

Re: Build 5.0.218

Post by Jim Rockford »

My problem is simple - your new build didn't install properly. I followed the download link as prompted by FBackup (i.e. "would you like to update now?"), and upon attempting to run the executable I was informed that build 192 had already been installed. In other words, the "update" was not actually an update at all. Or if it was, it didn't recognize itself as one. What I'm saying ought to be crystal clear.

UPDATE: As of Wednesday 12pm (EST USA) the update link to Build 218 actually points to the update, not an older version...unlike yesterday.

Jim

Post Reply