Flushing Win buffers????

You can ask general questions, share opinions or advices about FBackup
HandyHomme
Posts: 10
Joined: Mon May 30, 2011 12:31 pm

Postby HandyHomme » Thu Jun 02, 2011 4:37 am

Hi,


I just used the free version to do a full 13.7G backup of my data drive with Password from one USB drive to another USB on the same USB hub.


The drive light on the Target drive has been flashing for almost an hour since shutting down FBackup after it announced a success.


Windows will not let me "Safely Remove Drive F:" as it says it is still in use by another program. My guess is FBackup does not flush write buffers.


If I check the Zip it has made for a backup, the little magnifying glass just rattles around on it. If I double-click the Zip it opens it but never displays the Folder structure even though it finished it's count of 68,000 files.


The backup started at 3:14pm and ended at 4:33pm, but that's not the half of it, I can't shut down the PC as it is still writing to the Target drive.


How can I make the end of the back up coincide with the end of the writing. It is now 5:27pm and I am still waiting to Safely Remove drive F:.


OK, at 5:36pm it stopped flashing and I am finally able to Remove drive F: The computer has been sitting unused since FBackup started at 3:14pm. That's a looooong backup time.



HandyHomme
Posts: 10
Joined: Mon May 30, 2011 12:31 pm

Postby HandyHomme » Thu Jun 02, 2011 8:39 pm

Oooops, my mistake. After a lot of digging it turned out to be a non-visible second copy of Explorer trying to unpack the Zip. I don't know if it is Vista, Explorer or winRAR (my un-Zip-er) causing the problem, but it is not FBackup.


By loading the task manager I killed off the second copy of Explorer, which by the way was using over 50% of CPU time and the problem went away.




Return to “General”