Backup job doesn't fail but does nothing

Post here if you have problems installing or using FBackup
szeller
Posts: 12
Joined: Wed Aug 20, 2014 10:12 pm

Backup job doesn't fail but does nothing

Postby szeller » Wed Aug 20, 2014 10:18 pm

I am running FBackup 5.1.558.0 as an administrator on a Windows Server 2012 system. The job I am trying to run is a scheduled mirror backup of a local external drive to a local network repository.

The job starts and completes almost instantly, producing nothing in the network repository and only this in the log file:

[8/20/2014 5:05:03 PM] FBackup 5.1.558
[8/20/2014 5:05:03 PM] C:\Program Files (x86)\Softland\FBackup 5\bBackup.exe /R {BF62C753-FB26-4683-9E6F-5FCD7993045D} -PRIORITY 2
[8/20/2014 5:05:03 PM] Search for "Warning: " and "Error: " to locate warnings and errors in this log file
[8/20/2014 5:05:03 PM] Operating system: Windows server 2012 Datacenter Edition (build 9200)
Processor[0] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Processor[1] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Processor[2] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Processor[3] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Physical memory (free/total) : 7661 MB/12192 MB
Admin/BkPriv/RePriv : True/False/False
IsWOW64 : True
Locale : English (United States)

[8/20/2014 5:05:03 PM] Failed to set privilege SE_BACKUP_NAME : Not all privileges or groups referenced are assigned to the caller [1300]
[8/20/2014 5:05:03 PM] Failed to set privilege SE_RESTORE_NAME : Not all privileges or groups referenced are assigned to the caller [1300]
[8/20/2014 5:05:03 PM] Opening file "C:\Users\BackupConnection\AppData\Roaming\Softland\FBackup 5\FBackup.hst"
[8/20/2014 5:05:03 PM] Starting backup for "E Drive Data Backup" at 8/20/2014 5:05:03 PM
[8/20/2014 5:05:03 PM] Opening file "C:\Users\BackupConnection\AppData\Roaming\Softland\FBackup 5\Catalogs\E Drive Data Backup(2).fkc"
[8/20/2014 5:05:04 PM] Closing file "C:\Users\BackupConnection\AppData\Roaming\Softland\FBackup 5\Catalogs\E Drive Data Backup(2).fkc"
[8/20/2014 5:05:04 PM] Opening file "C:\Users\BackupConnection\AppData\Roaming\Softland\FBackup 5\Catalogs\E Drive Data Backup(2).fkc"

szeller
Posts: 12
Joined: Wed Aug 20, 2014 10:12 pm

Re: Backup job doesn't fail but does nothing

Postby szeller » Thu Aug 21, 2014 6:30 pm

I also have a similar log file when attempting to backup an internal drive.

I will attempt to run one of the jobs while logged in as the user that created the job.

szeller
Posts: 12
Joined: Wed Aug 20, 2014 10:12 pm

Re: Backup job doesn't fail but does nothing

Postby szeller » Thu Aug 21, 2014 9:27 pm

Running directly from the job author's account seems to be doing something as the catalog-loading message has been up for ~half an hour.

So, something with the author's account and the task scheduler appears to not be completely correct.

szeller
Posts: 12
Joined: Wed Aug 20, 2014 10:12 pm

Re: Backup job doesn't fail but does nothing

Postby szeller » Fri Aug 22, 2014 1:05 pm

And the Loading Backup Catalog message is still up 17 hours later.

szeller
Posts: 12
Joined: Wed Aug 20, 2014 10:12 pm

Re: Backup job doesn't fail but does nothing

Postby szeller » Fri Aug 22, 2014 1:34 pm

The log file, after canceling the job (then restarting FBackup):

[8/22/2014 8:25:11 AM] FBackup 5.1.558
[8/22/2014 8:25:11 AM] C:\Program Files (x86)\Softland\FBackup 5\bBackup.exe /GUI {11111111-1111-1111-1111-222222222222} /JOB {BF62C753-FB26-4683-9E6F-5FCD7993045D}
[8/22/2014 8:25:11 AM] Search for "Warning: " and "Error: " to locate warnings and errors in this log file
[8/22/2014 8:25:11 AM] Operating system: Windows server 2012 Datacenter Edition (build 9200)
Processor[0] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Processor[1] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Processor[2] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Processor[3] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Physical memory (free/total) : 7463 MB/12192 MB
Admin/BkPriv/RePriv : True/True/True
IsWOW64 : True
Locale : English (United States)

[8/22/2014 8:25:21 AM] Ipc warning: Register failed : Timeout waiting for a reply to imtRegister 0. Action will run silently
[8/22/2014 8:25:31 AM] Ipc warning: GetRegisteredApps failed : Timeout waiting for a reply to imtRegister 0
[8/22/2014 8:26:58 AM] Error: Invalid command line parameter or no imtStart messager received!
[8/22/2014 8:27:08 AM] Ipc warning: Unregister failed : Timeout waiting for a reply to imtUnregister 0

szeller
Posts: 12
Joined: Wed Aug 20, 2014 10:12 pm

Re: Backup job doesn't fail but does nothing

Postby szeller » Fri Aug 22, 2014 2:15 pm

The FBackup 5 Service (bservice.exe) is running, and the following are listed as being allowed through the Windows Firewall:

FBackup 5
FBackup 5 bBackup app
FBackup 5 bRestore app
FBackup 5 bTest app

Should there be others?

szeller
Posts: 12
Joined: Wed Aug 20, 2014 10:12 pm

Re: Backup job doesn't fail but does nothing

Postby szeller » Fri Aug 22, 2014 3:30 pm

It is looking like BitDefender was in a bad state. After doing a repair on that, the Backup progressed farther (to a password request dialog) when I ran it while logged in as the job author.

I will see if the scheduled backup works now.

szeller
Posts: 12
Joined: Wed Aug 20, 2014 10:12 pm

Re: Backup job doesn't fail but does nothing

Postby szeller » Sat Aug 23, 2014 3:09 pm

The scheduled job failed with the original privilege issues and now the jobs can't be run with the user logged in (getting the same ipc warnings and the interminable hang).

szeller
Posts: 12
Joined: Wed Aug 20, 2014 10:12 pm

Re: Backup job doesn't fail but does nothing

Postby szeller » Sat Aug 23, 2014 3:23 pm

BitDefender was again repaired. This required a reboot, so it is unclear if the reboot was what allows me to know start the job when logged in (i.e. not as a scheduled job).

The other thing that was going on was that I had switched users (rather than signing out and back in as a different user); BitDefender didn't allow me to run a repair in this case (does FBackup not like that?).

I will try to run the mirror backup jobs manually to see if they actually complete.

szeller
Posts: 12
Joined: Wed Aug 20, 2014 10:12 pm

Re: Backup job doesn't fail but does nothing

Postby szeller » Mon Aug 25, 2014 1:37 pm

One of the two backup jobs completed when I did them logged in as the job author; the other failed for a variety of reasons that I am looking into (242 MB log file).

The successful one again failed (as in the start of this thread, with the privilege issues) when the job scheduled for the next day was attempted. I should add, however, that the application reported SUCCESS even though the log file doesn't look like it:

[8/24/2014 6:30:06 PM] FBackup 5.1.558
[8/24/2014 6:30:06 PM] C:\Program Files (x86)\Softland\FBackup 5\bBackup.exe /R {BF62C753-FB26-4683-9E6F-5FCD7993045D} -PRIORITY 2
[8/24/2014 6:30:06 PM] Search for "Warning: " and "Error: " to locate warnings and errors in this log file
[8/24/2014 6:30:06 PM] Operating system: Windows server 2012 Datacenter Edition (build 9200)
Processor[0] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Processor[1] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Processor[2] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Processor[3] : Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz
Physical memory (free/total) : 7373 MB/12192 MB
Admin/BkPriv/RePriv : True/False/False
IsWOW64 : True
Locale : English (United States)

[8/24/2014 6:30:06 PM] Failed to set privilege SE_BACKUP_NAME : Not all privileges or groups referenced are assigned to the caller [1300]
[8/24/2014 6:30:06 PM] Failed to set privilege SE_RESTORE_NAME : Not all privileges or groups referenced are assigned to the caller [1300]
[8/24/2014 6:30:16 PM] Ipc warning: Register failed : Timeout waiting for a reply to imtRegister 0. Action will run silently
[8/24/2014 6:30:26 PM] Ipc warning: GetRegisteredApps failed : Timeout waiting for a reply to imtRegister 0
[8/24/2014 6:30:26 PM] Opening file "C:\Users\BackupConnection\AppData\Roaming\Softland\FBackup 5\FBackup.hst"
[8/24/2014 6:30:26 PM] Starting backup for "E Drive Data Backup" at 8/24/2014 6:30:26 PM
[8/24/2014 6:30:26 PM] Opening file "C:\Users\BackupConnection\AppData\Roaming\Softland\FBackup 5\Catalogs\E Drive Data Backup(5).fkc"
[8/24/2014 6:30:27 PM] Checking if the drives of the sources exist
[8/24/2014 6:30:30 PM] Checking backup destination (Network)
[8/24/2014 6:30:30 PM] Creating the list of files to backup
[8/24/2014 6:30:30 PM] Opening file ":memory:"
[8/24/2014 6:30:31 PM] Cannot use USN journal for this backup. Reason: USN journal disabled in settings
[8/24/2014 6:33:03 PM] Found folder E:\System Volume Information
[8/24/2014 6:33:07 PM] Closing file ":memory:"
[8/24/2014 6:33:07 PM] Folders found to backup: 1
[8/24/2014 6:33:07 PM] Files found to backup: 0 (0 KB)

[8/24/2014 6:33:08 PM] Preparing shadow copy
[8/24/2014 6:33:10 PM] Shadow copy created for drives E:
[8/24/2014 6:33:11 PM] Added folder E:\System Volume Information

[8/24/2014 6:33:12 PM] Saving backup catalog "C:\Users\BackupConnection\AppData\Roaming\Softland\FBackup 5\Catalogs\E Drive Data Backup(5).fkc"

[8/24/2014 6:33:13 PM] Remove excluded or deleted files from backup
Total number of files added to backup: 0
Total number of folders added to backup: 1
Total size of files added to backup: 0 KB
Number of files excluded: 0
Number of folders excluded: 0
Next scheduled backup: 8/25/2014 6:30:00 PM
Backup completed at 8/24/2014 6:33:19 PM with 0 error(s), 0 warning(s)
[8/24/2014 6:33:22 PM] Closing file "C:\Users\BackupConnection\AppData\Roaming\Softland\FBackup 5\Catalogs\E Drive Data Backup(5).fkc"
[8/24/2014 6:33:32 PM] Ipc warning: Unregister failed : Timeout waiting for a reply to imtUnregister 0
[8/24/2014 6:33:32 PM] Closing file "C:\Users\BackupConnection\AppData\Roaming\Softland\FBackup 5\FBackup.hst"


Return to “Troubleshooting”