FBackup 5 schedule runs but does nothing

Post here if you have problems installing or using FBackup
faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

Re: FBackup 5 schedule runs but does nothing

Postby faulkn_c » Tue Mar 25, 2014 2:27 pm

Hi,
I will re-schedule the backup to when I can be logged in and see what happens.
It may be a few days from now, as I am away for the rest of the week.

Since I started this thread I have updated to version 5.0.389.
Thanks for the help.
Colin

faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

Re: FBackup 5 schedule runs but does nothing

Postby faulkn_c » Sun Mar 30, 2014 10:53 am

I think I'm going to have to give up on this.
I'd re-scheduled the mirror to run at 7.00am this morning, but nothing was copied.
Again the schedulers history for the task showed that it ran for about a minute.
I tried attaching the logs for 30/03/2014, but they aren't allowed, so I've sent them to to info[at]fbackup[dot]com.
Doesn't look like there is enough debug info there to indicate why it quits so quickly.
Colin

muj
Posts: 1
Joined: Mon Mar 31, 2014 5:54 am

Re: FBackup 5 schedule runs but does nothing

Postby muj » Mon Mar 31, 2014 6:04 am

More or less the same thing is happening here.

I have two backup jobs on a Windows XP SP3 machine. They both seem to run but no new backups are being created. The Windows task scheduler log shows the following. I'm pasting the log as code for clarity.

Code: Select all

"fba_New Backup (1).job" (bSchedStarter.exe)
   Started 3/31/2014 1:00:00 AM
"fba_New Backup (1).job" (bSchedStarter.exe)
   Finished 3/31/2014 1:00:02 AM
   Result: The task completed with an exit code of (0).

"fba_local_site.job" (bSchedStarter.exe)
   Started 3/31/2014 2:05:00 AM
"fba_local_site.job" (bSchedStarter.exe)
   Finished 3/31/2014 2:05:02 AM
   Result: The task completed with an exit code of (0).


Just troubleshooting. If anyone with a hint to resolve this issue please help!

Softland
Posts: 1666
Joined: Thu May 23, 2013 7:57 am

Re: FBackup 5 schedule runs but does nothing

Postby Softland » Fri Apr 04, 2014 2:07 pm

Hi,

We do not have such problems here.
Please try the following:
1. Manually create a new scheduled task for another application from Control Panel->Administrative Tools->Task Scheduler.
Does it works?
2. If yes, try to see the difference between that task and the task created by FBackup.

faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

Re: FBackup 5 schedule runs but does nothing

Postby faulkn_c » Sun Apr 06, 2014 8:50 am

I've actually made some progress, things have been a bit protracted as I've been in and out of hospital for surgery :?
I've tried all the usual Softland suggestions, being logged in/out, creating schedule tasks manually etc. etc. with success/failure but nothing pointed to or indicated why the schedule would kick off FBackup, which then failed to act.

NOTE. The Windows scheduler always logged a return code of 0, to show it started the program/process successfully, but it can't 'know' if the program/process runs as there is no 'hand shake' after the called program/process finishes.

So I spent a day changing the schedule execution time from weekly to daily and getting it to run while I could watch it.
I set the execution time to start an hour later (to allow my NAS to go to sleep) and put the laptop into Hibernate.
The backup tasks failed to run consistently.

Then I disabled the 'Show Tray Icon' in FBackup Options>Startup and every subsequent scheduled backup worked!
Even when I re-enabled the Tray Icon they still worked.

So I can only assume that bTray.exe process was somehow corrupted and not allowing/calling the FBackup.exe from executing.

I'm now leaving the Tray Icon off, to see how it behaves, as it's purpose/function is questionable - even when you click on it after a backup (even if it shows an ! mark) is says 'No Messages' - so what's the point in it?

I know FBackup is free, but there doesn't seem to be any way to resolve these scheduler problems via Softland.
Having people debug the a program is useful to Softland as they can then roll the fix into Bachup4all - no problem with that as it's beneficial to all

But I'm so glad I didn't fork out money for Backup4all as I can't see how my problems would have ever been resolved.

I'ts a great program - when it works! - but you rely on a backup program to WORK RELIABLY - otherwise you don't have a backup.
In the meantime I'll keep trawling through the other SYNC/Backup programs and when I find one that is convenient AND reliable I'll pay for it.
Thanks and good luck,
Colin

drkshady
Posts: 2
Joined: Mon Apr 07, 2014 10:04 am

Re: FBackup 5 schedule runs but does nothing

Postby drkshady » Mon Apr 07, 2014 10:21 am

Seems like many people got these problems for months, including me.

I was thinking of buying Backup4All, but if you people can't fix something as trivial as this...

Please fix the problem, else theres no reason to keep your program.

faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

Re: FBackup 5 schedule runs but does nothing

Postby faulkn_c » Mon Apr 07, 2014 11:07 am

I spoke too soon, I reset the backup to run at 7.30am this morning, no Tray Icon and guess what? - it failed.
The only logs are from the Windows Scheduler history and one 'bSchedStarter_20140407073043.log' which listed below:

Code: Select all

5 entries in Windows Task Scheduler history for  07/04/2014 @ 07.30am:

Task Scheduler launch task "\Softland\FBackup 5\fba_Weekly Backup", instance "C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE" with process ID 3576.

Task Scheduler started "{e020a0bc-a3bb-4325-b7c1-82fc0dbed431}" instance of the "\Softland\FBackup 5\fba_Weekly Backup" task for user "Vostro1700\colin".

Task Scheduler launched action "C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE" in instance "{e020a0bc-a3bb-4325-b7c1-82fc0dbed431}" of task "\Softland\FBackup 5\fba_Weekly Backup".

Task Scheduler successfully completed task "\Softland\FBackup 5\fba_Weekly Backup" , instance "{e020a0bc-a3bb-4325-b7c1-82fc0dbed431}" , action "C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE" with return code 0.

Task Scheduler successfully finished "{e020a0bc-a3bb-4325-b7c1-82fc0dbed431}" instance of the "\Softland\FBackup 5\fba_Weekly Backup" task for user "Vostro1700\colin".


Only entry in FBachup5 log file folder for  07/04/2014 @ 07.30am:

bSchedStarter_20140407073043.log
[07/04/2014 07:30:49] FBackup 5.0.389 ()
[07/04/2014 07:30:49] C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE /R {8482B147-09F7-486C-B76F-7240B258380A} -PRIORITY 4
[07/04/2014 07:30:49] Operating system: Windows 8 Professional  (build 9200)
   Processor[0] : Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz
   Processor[1] : Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz
   Physical memory (free/total) :  2449 MB/3070 MB
   Admin/BkPriv/RePriv : True/False/False
   IsWOW64 : False
   Locale : English (United Kingdom)

[07/04/2014 07:30:49] bSchedstarter was started with the following command line
   "C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE" /R "{8482B147-09F7-486C-B76F-7240B258380A}" -PRIORITY 4
[07/04/2014 07:30:49] User is not logged on.
[07/04/2014 07:30:49] Sending request to service with params /R "{8482B147-09F7-486C-B76F-7240B258380A}" -PRIORITY "4"

Looks like there is no point in continuing trying to fix it myself......

Softland
Posts: 1666
Joined: Thu May 23, 2013 7:57 am

Re: FBackup 5 schedule runs but does nothing

Postby Softland » Thu Apr 10, 2014 9:55 am

@drkshady: FBackup scheduler is working fine. If there is a particular case in which the scheduler is not working properly, we are willing to find and fix it.

@faulkn_c: you did not mention a word about the latest test I asked you to perform. You said the scheduler failed at 7.30 AM. Does that mean it started and the backup failed? or it failed to start? There has to be a difference on your computer when the scheduler works and when it doesn't.

faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

Re: FBackup 5 schedule runs but does nothing

Postby faulkn_c » Thu Apr 10, 2014 4:06 pm

@Softland: which latest test? - the one you asked in an email or these posts?
I have tried creating scheduled tasks for other programs and FBackup manually, they all work apart from the FBackup tasks.
Scheduler History always show the task being kicked off.
My last post shows that the scheduler didn't fail, at 7.30 it kicked off FBackup.
See:

Code: Select all

5 entries in Windows Task Scheduler history for  07/04/2014 @ 07.30am:

Task Scheduler launch task "\Softland\FBackup 5\fba_Weekly Backup", instance "C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE" with process ID 3576.

Task Scheduler started "{e020a0bc-a3bb-4325-b7c1-82fc0dbed431}" instance of the "\Softland\FBackup 5\fba_Weekly Backup" task for user "Vostro1700\colin".

Task Scheduler launched action "C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE" in instance "{e020a0bc-a3bb-4325-b7c1-82fc0dbed431}" of task "\Softland\FBackup 5\fba_Weekly Backup".

Task Scheduler successfully completed task "\Softland\FBackup 5\fba_Weekly Backup" , instance "{e020a0bc-a3bb-4325-b7c1-82fc0dbed431}" , action "C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE" with return code 0.

Task Scheduler successfully finished "{e020a0bc-a3bb-4325-b7c1-82fc0dbed431}" instance of the "\Softland\FBackup 5\fba_Weekly Backup" task for user "Vostro1700\colin".



The only FBackup log generated was at 7:30:49 "bSchedStarter_20140407073043.log" as shown below:

Code: Select all

bSchedStarter_20140407073043.log
[07/04/2014 07:30:49] FBackup 5.0.389 ()
[07/04/2014 07:30:49] C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE /R {8482B147-09F7-486C-B76F-7240B258380A} -PRIORITY 4
[07/04/2014 07:30:49] Operating system: Windows 8 Professional  (build 9200)
   Processor[0] : Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz
   Processor[1] : Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz
   Physical memory (free/total) :  2449 MB/3070 MB
   Admin/BkPriv/RePriv : True/False/False
   IsWOW64 : False
   Locale : English (United Kingdom)

[07/04/2014 07:30:49] bSchedstarter was started with the following command line
   "C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE" /R "{8482B147-09F7-486C-B76F-7240B258380A}" -PRIORITY 4
[07/04/2014 07:30:49] User is not logged on.
[07/04/2014 07:30:49] Sending request to service with params /R "{8482B147-09F7-486C-B76F-7240B258380A}" -PRIORITY "4"


Both were in my previous post......

The backup didn't run.
No changes have been made to the computer/software - apart from 'upgrading' to the FBackup version 5.0.414.
At 7.30am no one is logged in and the computer is in hibernation.
Task scheduler wakes it up and calls FBackup, bSchedstarter kicks off, generates the above log file and finishes by:
"Sending request to service with params /R "{8482B147-09F7-486C-B76F-7240B258380A}" -PRIORITY "4"

The FBackup5Srv service is enabled and running.

That's all I know......
Colin

Softland
Posts: 1666
Joined: Thu May 23, 2013 7:57 am

Re: FBackup 5 schedule runs but does nothing

Postby Softland » Fri Apr 11, 2014 8:09 am

Hi,

Please try the following:
1. Change the scheduler to run after 1 minute, while you are in front of the computer.
2. If it runs, change the scheduler to run after few minutes, and you need to log off before the backup starts. Wait for the backup to finish and log in. Did the backup ran?


Return to “Troubleshooting”