FBackup 5 schedule runs but does nothing

Post here if you have problems installing or using FBackup
faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

FBackup 5 schedule runs but does nothing

Postby faulkn_c » Mon Mar 17, 2014 10:41 am

I've used FBackup for while and it has been a useful program, many thanks Softland, but now it is letting me down.
I have a mirror backup scheduled to run at 23.59 each Sunday night to copy changed files to my NAS.
My Win8 laptop currently has FBackup 5.0.389 installed, but I've never had the windows scheduler work reliably on any version.
I enabled History in the Task Scheduler and looking at the log files, the backup starts, but finishes (successfully) without doing anything and FBackup doesn't create it own log file.
The laptop is in hibernate/sleep (and probably so is my NAS) when the backup starts, but obviously the laptop wakes up to run the task.
Recently my Win7 laptop which has run FBackup 4.? reliably for months has started to fail to come out of hibernate to backup too.....

Anyone any ideas?
Thanks

Softland
Posts: 1666
Joined: Thu May 23, 2013 7:57 am

Re: FBackup 5 schedule runs but does nothing

Postby Softland » Mon Mar 17, 2014 2:11 pm

Hi,

First, please try to schedule that job to run when you are in front of the computer. Does it work?
Second, try to schedule another application to wake up the computer and run (under the same conditions), using the Windows Scheduler from Control Panel.
If both works, please compare the scheduled task created by FBackup with the one you manually created.
Are there any permissions different ?

faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

Re: FBackup 5 schedule runs but does nothing

Postby faulkn_c » Mon Mar 17, 2014 10:29 pm

Hi, many thanks for the reply, but forgive me I'm struggling.....
I rescheduled the job and it ran while I watched, but even though I'd ticked the 'Show main application' box, nothing showed up as running.
But using Task Manager showed it running as a process in the background, it completed and no errors were shown in the FBackup log file.
I'm pulling my hair out trying to get the Scheduler to work.
I can define a Basic Task, such as running: C:\Windows\System32\notepad.exe but nothing happens when I click on RUN
The History shows:

Log Name: Microsoft-Windows-TaskScheduler/Operational
Source: Microsoft-Windows-TaskScheduler
Date: 17/03/2014 22:22:52
Event ID: 110
Task Category: Task triggered by user
Level: Information
Keywords:
User: SYSTEM
Computer: Vostro1700
Description:
Task Scheduler launched "{3607d0f7-f1ec-45a1-b893-b60d421c187b}" instance of task "\Microsoft\Basic Task" for user "colin" .
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-TaskScheduler" Guid="{DE7B24EA-73C8-4A09-985D-5BDADCFA9017}" />
<EventID>110</EventID>
<Version>0</Version>
<Level>4</Level>
<Task>110</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2014-03-17T22:22:52.856780800Z" />
<EventRecordID>43559</EventRecordID>
<Correlation ActivityID="{3607D0F7-F1EC-45A1-B893-B60D421C187B}" />
<Execution ProcessID="1116" ThreadID="4444" />
<Channel>Microsoft-Windows-TaskScheduler/Operational</Channel>
<Computer>Vostro1700</Computer>
<Security UserID="S-1-5-18" />
</System>
<EventData Name="TaskRunEvent">
<Data Name="TaskName">\Microsoft\Basic Task</Data>
<Data Name="InstanceId">{3607D0F7-F1EC-45A1-B893-B60D421C187B}</Data>
<Data Name="UserContext">colin</Data>
</EventData>
</Event>

Obviously I'm doing something wrong, so I can't try your next step - just yet.....

faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

Re: FBackup 5 schedule runs but does nothing

Postby faulkn_c » Mon Mar 17, 2014 10:46 pm

Update,
Just checked with Task Manager - Notepad is running, but nothing shows on screen....
When I click 'End' in Scheduler it stops!
Why can't I see anything happening?

faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

Re: FBackup 5 schedule runs but does nothing

Postby faulkn_c » Tue Mar 18, 2014 10:24 am

Right, I now see that background execution is by design, I can get it to run in the foreground by ticking 'Run only when user is logged on'

If I schedule notepad like the FBackup task is and set the laptop into hibernate, it works, laptop wakes up and notepad is running as a process.
Tried exactly the same with the FBackup task, which started up as scheduled at 10.15, but again ran without doing anything, the scheduler history shows:

Log Name: Microsoft-Windows-TaskScheduler/Operational
Source: Microsoft-Windows-TaskScheduler
Date: 18/03/2014 10:16:49
Event ID: 102
Task Category: Task completed
Level: Information
Keywords: (1)
User: SYSTEM
Computer: Vostro1700
Description:
Task Scheduler successfully finished "{3abf4c04-f5a5-4b42-80ff-2371e5cc17b7}" instance of the "\Softland\FBackup 5\fba_Weekly Backup" task for user "Vostro1700\colin".
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-TaskScheduler" Guid="{DE7B24EA-73C8-4A09-985D-5BDADCFA9017}" />
<EventID>102</EventID>
<Version>0</Version>
<Level>4</Level>
<Task>102</Task>
<Opcode>2</Opcode>
<Keywords>0x8000000000000001</Keywords>
<TimeCreated SystemTime="2014-03-18T10:16:49.124627700Z" />
<EventRecordID>44138</EventRecordID>
<Correlation ActivityID="{3ABF4C04-F5A5-4B42-80FF-2371E5CC17B7}" />
<Execution ProcessID="1116" ThreadID="7512" />
<Channel>Microsoft-Windows-TaskScheduler/Operational</Channel>
<Computer>Vostro1700</Computer>
<Security UserID="S-1-5-18" />
</System>
<EventData Name="TaskSuccessEvent">
<Data Name="TaskName">\Softland\FBackup 5\fba_Weekly Backup</Data>
<Data Name="UserContext">Vostro1700\colin</Data>
<Data Name="InstanceId">{3ABF4C04-F5A5-4B42-80FF-2371E5CC17B7}</Data>
</EventData>
</Event>

Again no FBackup log was generated.

Softland
Posts: 1666
Joined: Thu May 23, 2013 7:57 am

Re: FBackup 5 schedule runs but does nothing

Postby Softland » Tue Mar 18, 2014 2:06 pm

Hi,

Do you use an administrator account?
If you check the option to "Run only when user is logged on", the scheduler won't run if the computer is in sleep/hibernate mode.

faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

Re: FBackup 5 schedule runs but does nothing

Postby faulkn_c » Tue Mar 18, 2014 3:52 pm

Hello again,
My account is as an administrator, normally 'Run only when user is logged on' is unticked, I ticked it just to get notepad.exe to run in the foreground.
Why would FBackup run, but close down again after only a few minutes? - does it log error codes/messages anywhere else? - or is there a debug option?
Seems I need to rule out a NAS (sleep?) problem, I'll try again but schedule a backup to an attached USB drive later tonight.
Thanks,
Colin

Softland
Posts: 1666
Joined: Thu May 23, 2013 7:57 am

Re: FBackup 5 schedule runs but does nothing

Postby Softland » Fri Mar 21, 2014 12:41 pm

Hi,

Please send us the last backup log for that job, to info[at]fbackup[dot]com

faulkn_c
Posts: 14
Joined: Mon Mar 17, 2014 10:21 am

Re: FBackup 5 schedule runs but does nothing

Postby faulkn_c » Mon Mar 24, 2014 9:47 am

Hi,
I can't send you an FBackup log, as when the backup fails it leaves no log file.
As I have enable logging/history in the Windows scheduler, if I look at the scheduler log, I can see that it starts, but only runs for a few minutes.
No full FBackup log exists.
For example, this is all I have:

FBackup bSchedStarter_20140316235907.log
[16/03/2014 23:59:08] FBackup 5.0.389 ()
[16/03/2014 23:59:08] C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE /R {8482B147-09F7-486C-B76F-7240B258380A} -PRIORITY 4
[16/03/2014 23:59:08] Operating system: Windows 8 Professional (build 9200)
Processor[0] : Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz
Processor[1] : Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz
Physical memory (free/total) : 2407 MB/3070 MB
Admin/BkPriv/RePriv : True/False/False
IsWOW64 : False
Locale : English (United Kingdom)

[16/03/2014 23:59:08] bSchedstarter was started with the following command line
"C:\Program Files\Softland\FBackup 5\bSchedStarter.EXE" /R "{8482B147-09F7-486C-B76F-7240B258380A}" -PRIORITY 4
[16/03/2014 23:59:08] User is not logged on.
[16/03/2014 23:59:08] Sending request to service with params /R "{8482B147-09F7-486C-B76F-7240B258380A}" -PRIORITY "4"

This is all I have, but I will send the file.
Thanks,
Colin

Softland
Posts: 1666
Joined: Thu May 23, 2013 7:57 am

Re: FBackup 5 schedule runs but does nothing

Postby Softland » Tue Mar 25, 2014 1:21 pm

Hi,

Do you have the same problem if you are logged in at the scheduler time?


Return to “Troubleshooting”