How long before directories are deleted?

Post here if you have problems installing or using FBackup
Post Reply
neobackups
Posts: 1
Joined: Mon Jan 02, 2023 6:44 pm

How long before directories are deleted?

Post by neobackups »

Hi,

I just upgraded from FBackup to Backup4All.

When running FBackup, it had a problem when I would delete directories on the Source that had other subdirectories in them. In the Destination, it would remove the directories from disk, but not from the catalog. So the backups would have Warnings in the logs saying "cannot delete folder" because, of course, the folder no longer existed.

I upgraded to Backup4All hoping to fix this.

Backup4All successfully imported my backup jobs (all Mirror type) and I removed FBackup. When I run the backup jobs now, they complete successfully with no errors.

However, I now see that all of the deleted directories - that do not exist in the Source - have appeared in the Destination. It seems that Backup4All just created the missing directories in the Destination.

Since they were deleted in the Source, will they eventually be deleted from the Destination? Or is there some kind of rebuild that I need to do on the job's catalog?

Please advise. Thanks!

Adrian (Softland)
Posts: 1914
Joined: Thu May 23, 2013 7:57 am

Re: How long before directories are deleted?

Post by Adrian (Softland) »

Hi,

If there were warnings while trying to delete the folders, it means they remained in destination since that moment.
If it was recently or with the current build, we should investigate the situation to see why the warnings appeared. Can you send us the backup log for that execution?
Do you know you can monitor your backups remotely with Backup4all Monitor? You can read more here: https://www.backup4all.com/backup4all-monitor.html

fitness88
Posts: 79
Joined: Mon Dec 19, 2011 5:55 pm

Re: How long before directories are deleted?

Post by fitness88 »

I too have had this exact same issue with some backups using FBackup...in time it eventually resolves itself.

Here is an example, the folder was not on my source or destination at the time of this backup so it must be seeing the folder in the catalogue:
[1/07/23 11:53:07 PM] Warning: Cannot delete folder: "H:\all files\D\executables\dcs\sw_open comp\OpenComposite\"

This photo is from my source.
Attachments
Screenshot 2023-01-08 124514.png
Screenshot 2023-01-08 124514.png (26.94 KiB) Viewed 100 times

Adrian (Softland)
Posts: 1914
Joined: Thu May 23, 2013 7:57 am

Re: How long before directories are deleted?

Post by Adrian (Softland) »

Hi,

If the destination folder is not there (it was probably deleted outside FBackup), it cannot be deleted.
Do you know you can monitor your backups remotely with Backup4all Monitor? You can read more here: https://www.backup4all.com/backup4all-monitor.html

fitness88
Posts: 79
Joined: Mon Dec 19, 2011 5:55 pm

Re: How long before directories are deleted?

Post by fitness88 »

"If the destination folder is not there (it was probably deleted outside FBackup), it cannot be deleted."

I never delete/edit in any way the backed up destination folders/files. The only place I delete/edit folders/files is at the source. So that being the case...when the next backup is run, if a source folder/file has been deleted/edited there should not be a "warning".

Adrian (Softland)
Posts: 1914
Joined: Thu May 23, 2013 7:57 am

Re: How long before directories are deleted?

Post by Adrian (Softland) »

Hi,

Do you get that warning every time for the same folder?
Or it was only once when the first time occurred.
Do you know you can monitor your backups remotely with Backup4all Monitor? You can read more here: https://www.backup4all.com/backup4all-monitor.html

fitness88
Posts: 79
Joined: Mon Dec 19, 2011 5:55 pm

Re: How long before directories are deleted?

Post by fitness88 »

It resolves itself with 'no warnings' showing up usually by the next backup a week later...I can then go weeks without warnings.

Adrian (Softland)
Posts: 1914
Joined: Thu May 23, 2013 7:57 am

Re: How long before directories are deleted?

Post by Adrian (Softland) »

Hi,

Thanks for your answer.
I'm glad the problem is gone.
Do you know you can monitor your backups remotely with Backup4all Monitor? You can read more here: https://www.backup4all.com/backup4all-monitor.html

Post Reply