Page 3 of 5

Posted: Sun Jul 11, 2010 4:37 pm
by msc
I'm new to the forum and just found this thread.
I too am occasionally getting the error during a backup: "VscSrv.exe has encountered a problem and needs to close."
I have FBackup 4.4 build 213. (XP SP-3 32 bit)
I see the last admin post was 6 months ago. Is there a fix for this problem?
(I can't find any "manual" settings for "Volume Shadow Copy service" mentioned above.)

Posted: Tue Jul 13, 2010 1:12 pm
by Adrian (Softland)
Please follow these steps to set the Volume Shadow Copy to manual:

Go to Start -> Control Panel -> Administrative tools -> Services.

Make sure the “Volume Shadow Copy” service is started and set to Manual.

Posted: Tue Jul 13, 2010 5:30 pm
by msc
It is set to "Manual"
Other reasons for this "VscSrv.exe has encountered a problem and needs to close" error?

Posted: Tue Jul 13, 2010 5:45 pm
by Adrian (Softland)
We found that for some OS, the error appears. We will fix that problem.

Posted: Fri Jul 16, 2010 11:52 pm
by lawtech
With latest FBackup update (installed today), the vscsrv.exe error occurs. This happens even when Volume Shadow Copy is started before the update, after the update and then restarted again. Somehow it appears to get turned off- it still reads "started" but it gives the error message and has the option to restart - not after every backup session but intermittently throughout the day. This is a Windows 7 OS.

Posted: Mon Jul 19, 2010 5:18 pm
by Adrian (Softland)
The new release with the fix is not ready yet.

Posted: Wed Jul 21, 2010 5:50 am
by Donna77642
Hello, I am using a clean install of Windows 7 (upgrade from VISTA, but install wiped all of that out), and the VscSrv2008.exe has stopped working error still exists.
I had just decided to uninstall my former backup software and go with this one, but, if this error is going to still keep causing problems and not be fixed anytime soon, I don't think I can.
Do you have any idea when this issue might be fixed? Months, longer?
We REALLY appreciate your software, but anxiously await a fix to this issue.
Thank you!

Posted: Wed Jul 21, 2010 6:05 am
by Donna77642
Hey, I don't know if you are aware of it, but the same problem exists in Backup4All Professional. I don't know if the data below will help you solve the issued in FFbackup, but I have posted it here, just in case, because it is obviously related:
Report this postReply with quoteVscSrv2008.exe crashes

by Panos » Thu Jul 08, 2010 1:13 am
S/W: Backup4All Professional version unregistered (VscSrv2008.exe has no File Properties and, in particular, no File Version)

O/S: Vista Ultimate SP2 32-bit
I tried FBackup4 for a week, liked it and am now evaluating Backup4All Professional. I've already tried Mirror and Full types and have just set up a combination Full, Diff and Incremental.
I am backing up to an external HDD and the only problem I have so far is that a couple of minutes after a backup has started running (before it starts adding files and right about when VSS is started) Windows Error Reporting comes up to notify me that VscSrv2008.exe has crashed.
Here's what I get in the corresponding Event Log - Application Error entry:
Faulting application VscSrv2008.exe, version, time stamp 0x4c288582, faulting module ntdll.dll, version 6.0.6002.18005, time stamp 0x49e03821, exception code 0xc0000374, fault offset 0x000afaf8, process id 0xd48, application start time 0x01cb1e201902294e.

You may find the exception code useful. There is a WER report as well.
The crash does not seem to affect the progress of the backup. Files are getting added and the backup completes successfully. I have done no comprehensive testing but I can navigate through the backed up file structure and open up any number of backed up files. No other exceptions are reported around that time. Even if I don't close the WER report, the backup continues.
What is the purpose of VscSrv2008.exe and is it possible to ascertain whether the crash happens before/after its work is done and whether it does affect the backup in some, perhaps not so obvious, way?
Thanks, again, Donna

Posted: Wed Jul 21, 2010 1:12 pm
by Adrian (Softland)
The backup is successful even if that message appears.

The VscSrv2008.exe file is used to back up open files.

The problem will be fixed is few days.

Posted: Wed Aug 11, 2010 11:18 pm
by msc
Glad to hear the problem will be fixed in a few days.
However, that was posted 3 weeks ago, and I have not seen any FBackup updates since then.
Has there been one that I somehow missed?