Page 2 of 4

Posted: Tue Mar 02, 2010 3:01 am
by DeMeul

Yes, it happens every time when I start a backup (either in full or in mirror mode) while the file is in use by Outlook 2003.

I excluded the file from scanning in McAfee without any success.

Even stopping scanning at all did not change the result.

No other virus/spyware applications are active or even installed.



Posted: Wed Mar 03, 2010 6:53 pm
by Softland

Hi,


Can you manually copy that file to another location?



Posted: Thu Mar 04, 2010 4:10 am
by DeMeul

No, when Outlook is active and thus using the file I get the error message 0x80070021.

The description, although in the local language, is indicating the same reason: a part of the file is in use by an other process.


When Outlook is inactive the file can be copied without problems, just like it happens when using Fbackup.


So it looks like Fbackup is not doing what it is supposed to do, namely bypassing this error.



Posted: Thu Mar 04, 2010 2:33 pm
by Softland

Hi,


It seems the problem is with the Shadow copy service.


Backing up open files has the following limitations: It works

- only on Windows XP, Windows 2003 Server, Windows Vista or Windows 7

- only for users with administrator access rights to copy open files

- only on local hard drives

- only on NTFS formatted partitions

- only if the VSS (Volume Shadow Service) is running and it is properly configured


If all of the above are true and still cannot backup open files please see this document



Posted: Wed Mar 10, 2010 3:39 am
by DeMeul

I fear the problem has something to do with VSS in combination with Windows 7.

I've doublechecked all points mentioned and they are all true.

I've read the document and all services etc are running.

I've installed other products (free downloads and evaluation versions) and they all ran into the same problem. One of the producers of a (commercial) tool is mentioning on his website that it is not working for Windows 7 yet.

Maybe you guys face the same problem.



Posted: Wed Mar 10, 2010 3:48 am
by DeMeul

In addition to my previous message:

The tool works fine under Windows XP Professional.

Under Windows 7 I've checked the working of the tool with Procmon (of Sysinternals) and it looks like the VSS is doing okay. When opening the original file after creating the VSS the error occurs.

When using Fbackup for the file OUTLOOK.PST in the mode "full" the tool no errors nor warnings occur, but the resulting zip file has a length of 0 bytes.



Posted: Wed Mar 10, 2010 5:04 pm
by Softland

Hi,


We don't have such problems here.

We can back up open files with FBackup under Windows 7 32-bit and 64-bit OS.

We have many other clients that use FBackup for open files without problems.


Please follow these steps:

1. Download and extract DebugView from http://download.sysinternals.com/Files/DebugView.zip.

2. Start DebugView

3. Start FBackup and run the backup.

4. Send us the debug log to info[at]fbackup[dot]com



Posted: Tue Mar 30, 2010 10:13 pm
by DeMeul

Hi,


I've done as requested and advised by mail, but the file downloaded and installed is not build 195 but 194. Nevertheless I've tested this version, unfortunately without success. Please let me know were I can find build 195 that may solve my problem.


Ton



Posted: Wed Mar 31, 2010 7:10 pm
by Softland

Hi,


Can you manually copy the PST file to another location while Outlook is running?



Posted: Thu Apr 01, 2010 1:15 am
by DeMeul

Hi,


No, I cannot copy the file manually while Outlook is active. Error code 0x80070021.


Ton