Page 1 of 1

IPC Service failure - again!!!

Posted: Thu Jan 29, 2015 8:41 pm
by Salisburyblue
I had a problem ages ago with the IPC service failing to start, so I added bService.exe to my firewall and normal service was resumed.

I am on Windows7 SP1 and FBackup5 was working perfectly well on an earlier v5 build (don't recall the build number - may have been 482).

I have just upgraded to v5.2.663 (but for some reason the download from your update notification would not work, so I had to uninstall the old version and install v5.2.663 from scratch, then redefine the backup job).

Now I have the same IPC Service problem again - bService.exe is still allowed through the firewall, but the application will not start.

UPDATE: problem resolved. I used Revo Uninstaller to remove build 663, opened Windows Firewall and removed all FBackup entries, then installed the latest build (685). It worked. So the issue has to be to do either with build 663 specifically or with flakiness in the process you use for version-to-version updates - possibly not removing old Firewall entries.

Brian Crabtree

Re: IPC Service failure - again!!!

Posted: Mon Feb 16, 2015 2:14 pm
by Salisburyblue
I just accepted a prompt to install a new build and the IPC server error came up after the new installation was done.

I deleted Backup5.ini from my Program data \ Softland folder and restarted FBackup5.

Windows reconfigured it automatically and the program worked.

The problem, therefore, may well be something to do with the way the .ini file is set up after an upgrade.

Please can you look into this and provide a fix for future occurrences?

Email me if you wish to look at my system, which is Windows7 Home Premium SP1.

Re: IPC Service failure - again!!!

Posted: Thu Feb 19, 2015 9:12 am
by Adrian (Softland)

Backup5.ini file is not related to the problem you had in your previous post.